Difference between revisions of "Prerequisites"

From TUDOS-Wiki
Jump to navigationJump to search
Line 14: Line 14:
 
To build the system you need the following:
 
To build the system you need the following:
 
* x86 Linux host system (64bit is also supposed to work)
 
* x86 Linux host system (64bit is also supposed to work)
* gcc/g++-4.1 or gcc/g++-4.2
+
* gcc and g++
 
* make
 
* make
 
* perl
 
* perl
* python
 
 
* gawk
 
* gawk
* sed
 
 
* libcurses-dev
 
* libcurses-dev
* bison/flex
 
  
 
Good to have:
 
Good to have:
Line 28: Line 25:
  
 
All those should be part of any recent Linux distribution.
 
All those should be part of any recent Linux distribution.
 
===Additional Packages===
 
 
Additional tools required by different packages:
 
 
* sdl
 
** automake 1.4
 

Revision as of 19:35, 10 November 2010

Human Requirements

Users using the system should know the following:

  • Basic understanding of a Linux based system for software development
  • How to work with a shell
  • Know what gcc is
  • What make is and how it's used
  • Understand the english language
  • For L4Linux: Know how to configure and compile the Linux kernel
  • Have a basic understanding on how an L4 system works, which components are involved and how they play together

Basic System

To build the system you need the following:

  • x86 Linux host system (64bit is also supposed to work)
  • gcc and g++
  • make
  • perl
  • gawk
  • libcurses-dev

Good to have:

  • subversion client
  • doxygen to build documentation

All those should be part of any recent Linux distribution.